Error syntax error, unexpected ‘use’ (T_USE) phpspreadsheet di Codeigniter

Posting kali ini adalah terkait pesan error “syntax error, unexpected ‘use’ (T_USE)” saat memasang Library PHPSpreadsheet di Codeigniter 2.0.

Adapun kondisi munculnya Pesan Error ini adalah ketika hendak menggunakan Library phpspreadsheet di Codeigniter v.2.0 dengan kronologi sebagai:

  1. Instalasi phpspreadsheet di codeigniter dengan menggunakan composer
  2. Call Library dengan menggunakan “require(‘../../../phpSpreadsheet/vendor/autoload.php’);”
  3. Penggunaan perintah : use PhpOffice\PhpSpreadsheet\Helper\Sample; use PhpOffice\PhpSpreadsheet\IOFactory; use PhpOffice\PhpSpreadsheet\Spreadsheet;

Pada saat penulisan baris Code pada poin 3 diatas, aplikasi Editor Text Visual Code menampilkan pesan error “Error syntax error, unexpected ‘use’ (T_USE)”.

Setelah melakukan searching ditemukan solusi dari error tersebut yakni dengan cara memindahkan baris script berikut ke bagian paling atas sebelum tag php atau diatas nama class

require(‘vendor/autoload.php’);
use PhpOffice\PhpSpreadsheet\Helper\Sample;
use PhpOffice\PhpSpreadsheet\IOFactory;
use PhpOffice\PhpSpreadsheet\Spreadsheet;
Mudahkan tips singkat ini dapat bermanfaat bagi teman-teman umumnya dan wabil khusus saya sendiri.
Iklan

Cara Mengatasi SnagIt Failed Save a Document

Aktifitas dalam Capture dan Edit Image menggunakan Aplikasi SnagIt memang sangat menyenangkan. Namun beberapa pekan terakhir ini setelah mendapat Lepi baru, SnagIt yang terinstall di lepi tersebut mulai bermasalah.
“Failed to Save Document”
Begitulah pesan yang ditampilkan setiap kali hendak melakukan penyimpanan hasil Capture.

Nah bagi Sobat Kupas Abis tidak perlu kuatir jika mengalami problem seperti diatas. Solusinya adalah sebagai berikut:

– Matikan Aplikasi SnagIt yang sudah berjalan melalui TaskManager (Ctlr+Alt+Del)
– Buka Explore kemudian masuk ke Library Document
– Cari Folder SnagIt
– Delete Folder tersebut
– Jalan kembali SnagIt

Demikian Tips yang bisa Kupas Abis sampaikan. Mudah-mudahan bermanfaat.

Write IP Address by Range in Address List Mikrotik

Terkadang membuat daftar ip address pada fitur address list di mikrotik sangat menjemukan. Apalagi kalau yang hendak dituliskan ada banyak IP Address,… Wow sangat menjemukan.

Nah pada kesempatan kali ini kupasabis.wordpress.com akan menjelaskan hingga tuntas tentang cara menuliskan sekaligus memasukkan 100 Ip Address secara otomatis di fitur Address List pada mikrotik.

Langsung saja simak tahapannya berikut ini:

  1. Silakan buka menu “New Terminal” dari mikrotik
  2. Ketikkan kode berikut:
    :for IP from=100 to=200 do={ /ip firewall address-list add list=”new_ip” address=”192.168.2.$IP” }
  3. akhiri dengan tekan “Enter”
  4. Silakan cek di Fitur Address List mikrotik

Berikut ini adalah penjelasan dari script diatas:

  • :for IP from=100 to 200
    Artinya mengidentifikasi IP Address dari IP xxx.xxx.xxx.100 hingga xxx.xxx.xxx.200
  • do
    Artinya perintah yang akan dilakukan pada range IP tersebut
  • /ip firewall address-list
    artinya masuk ke menu IP :: Firewall :: address-list
  • add list=”new_ip”
    artinya menambah daftar list ip baru dengan nama “new_ip”
  • address=”192.168.2.$IP”
    artinya pada list ip baru tsb yakni “new_ip”, masukkan dan tambahkan dengan ip address yang sudah teridentifikasi di awal, yakni 192.168.2.100 hingga 192.168.2.200

Demikian sedikit tips tentang cara memasukkan IP Address berdasarkan range ke address list mikrotik. Mudah-mudahan bermanfaat.

File dan Folder Sharing berwarna abu-abu dan bertanda silang

File da Folder Abu-abu dan bertanda silangAda hal yang aneh terjadi pada notebook saya. Seperti biasanya setelah dinyalakan langsung akses file dan folder di server melalui jaringan kantor. Kaget bukan kepalang ketika melihat tampilan di explorer, hampir semua file dan folder yang di share oleh server berwarna abu-abu dan bertanda silang.

Kenapa ya…. Padahal ada kebutuhan mendadak dan mendesak untuk segera menyelesaikan pekerjaan kemarin yang belum kelar.

Untuk mempercepat langsung cari solusinya di mbah google dan akhirnya ketemu pula solusinya

Berikut ini adalah solusi dari problematika yang saya hadapi: Baca lebih lanjut

Cara Menghapus White Space di Database Mysql

Menghapus White Space di Mysql

Menghapus White Space di Mysql

Lama sudah tak posting di blog ini. Kebetulan siang ini ada hal yang sangat remeh tapi bisa jadi dapat menimbulkan permasalahan yang besar.

Posting kali ini merupakan pengalaman penulis terkait proses import data excel ke database mysql. Dimana setelah melakukan proses import dan data berhasil masuk, saat dilakukan pengecekan ternyata banyak data yang tersimpan dengan space kosong di depan teks. Baca lebih lanjut

Memanggil File PHP melalui Task Scheduler Windows

scheduled-task-windows

scheduled-task-windows

Terkadang seorang programmer muda mengalami kesulitan ketika menghadapi sebuah kondisi dimana diharuskan untuk menjalankan php file berdasarkan waktu yang telah ditentukan (schedule task).

Sebenarnya ada banyak cara untuk dapat melakukan hal tersebut dan salah satunya adalah yang akan dibahas secara detail pada postingan kali ini yakni “Menjalankan File PHP melalui Task Scheduler Windows”. Baca lebih lanjut

Cara Delete Data Yang Tidak Ada Di Tabel Lain

imagesIni adalah postingan artikel pertama di tahun 2016. Sebelumnya kami ucapan selamat tahun baru 2016 Masehi. Semoga kita diberikan kemudahan, kelancaran, dan kesuksesan dalam menggapai cita dan cinta kita. Amin

Pembaca yang budiman, kali ini penulis akan memberikan tips tentang “Cara Delete Data Yang Tidak Ada Di Tabel Lain”.

Sebenarnya perihal di atas bukan hal baru, namun bagi seorang pembelajar di dunia PHP terkadang perihal tersebut diatas menjadi penghambat yang memakan banyak waktu. Olehkarenanya berikut ini penulis mencoba share beberapa cara terkait perihal diatas.

[ Situasi ]

Tabel Asli memiliki kolom `id` dan `nama`

Tabel Baru memiliki kolom `id` dan `noreg`

[ Pertanyaannya ]

Bagaimanakah jika ingin menghapus (delete) semua data di tabel B, `id`nya tidak ada di kolom `id` pada tabel A ?

[ Caranya ]

:: 01 ::  Menggunakan Left Join / Is Null

DELETE z FROM Baru z
  LEFT JOIN Asli y ON z.id = y.id 
      WHERE y.id IS NULL

:: 02 :: Menggunakan perintah Not In 
DELETE FROM Baru
 WHERE id NOT IN (SELECT a.id 
                        FROM Asli a)
:: 03 :: Menggunakan perintah Not Exists 
DELETE FROM Baru 
 WHERE NOT EXISTS(SELECT NULL
                    FROM Asli a
                   WHERE a.id = id)